package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\w+(\.|-)*\w+)+@(\w+-?\w+)+\.[a-z]{2,3}(\.[a-z]{2})?`)
var str = `abir.hasan.123@abir-hasan-limon.edu.bd
abir.spsc@gmail.com
sushipoo777@gmail.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}