re = /^(?:(?:\d|[1-9]\d|1\d\d|2[0-4]\d|25[0-5])(?:\.(?!$)|$)){4}$/
str = '127.0.0.1'
# Print the match result
str.match(re) do |match|
puts match.to_s
end