const regex = /(str)(?=(?:[^'"]|["'][^'"]*["'])*$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(str)(?=(?:[^\'"]|["\'][^\'"]*["\'])*$)', 'g')
const str = `test str , a "comma, si str", bobsi str "si,sam, str",here si str ' hh str si'`;
const subst = `newstr`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);