$re = '/\<((?:(?!\>).)+)/im';
$str = '<https://api.github.com/repositories/2164979/issues?page=2>; rel=\\"next\\", <https://api.github.com/repositories/2164979/issues?page=6>; rel=\\"last\\"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);