// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\d+|-\d+|-?\d{1,2}%|-?100%|(-?\d+<(-?\d{1,2}%|-?100%|-?\d+) )*(-?\d+<(-?\d{1,2}%|-?100%|-?\d+)))$").unwrap();
let string = "100%
1
-2
1<2 -2<50%
2<100%
-80%";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}