package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(19|20)\d\d`)
var str = `2016`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}