#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^((gir *0aa)|((((?![qvx])[a-z][a-hk-y]?[0-9][0-9]?)|(((?![qvx])[a-z][0-9][a-hjkstuw])|((?![qvx])[a-z][a-hk-y][0-9][abehmnprvwxy]))) *([0-9](?![cikmov])[a-z]{2}))|(((?![qvx])[a-z][a-hk-y]?[0-9][0-9]?)|((?![qvx])[a-z][0-9][a-hjkstuw])|((?![qvx])[a-z][a-hk-y][0-9][abehmnprvwxy])))$"
Local $sString = "GIR 0AA" & @CRLF & _
"" & @CRLF & _
"W1 6LS" & @CRLF & _
"N1C 4UQ" & @CRLF & _
"N17 6LA" & @CRLF & _
"SW8 1UQ" & @CRLF & _
"CW3 9SS" & @CRLF & _
"SE5 0EG" & @CRLF & _
"WC2H 7LT" & @CRLF & _
"WC1N 2PL" & @CRLF & _
"HU12 0AR" & @CRLF & _
"" & @CRLF & _
"N1C4UQ" & @CRLF & _
"N176LA" & @CRLF & _
"SW81UQ" & @CRLF & _
"CW39SS" & @CRLF & _
"SE50EG" & @CRLF & _
"WC2H7LT" & @CRLF & _
"WC1N2PL" & @CRLF & _
"HU120AR" & @CRLF & _
"" & @CRLF & _
"W1" & @CRLF & _
"N1C" & @CRLF & _
"N17" & @CRLF & _
"SW8" & @CRLF & _
"CW3" & @CRLF & _
"SE5" & @CRLF & _
"WC2H" & @CRLF & _
"WC1N" & @CRLF & _
"HU12" & @CRLF & _
"" & @CRLF & _
"QA12" & @CRLF & _
"AJ12" & @CRLF & _
"Q1A" & @CRLF & _
"A1V" & @CRLF & _
"QA1N" & @CRLF & _
"AZ1N" & @CRLF & _
"AB1Z"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")