$re = '/\b([\w]+) +(\1)\b/m';
$str = 'b ata ata';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);