# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^([0-9]|[1-9][0-9]|[1-9][0-9][0-9])$"
test_str = ("<--! select 0..999 sequences -->\n"
"0\n"
"9\n"
"00\n"
"09\n"
"10\n"
"99\n"
"000\n"
"001\n"
"002\n"
"004\n"
"010\n"
"011\n"
"021\n"
"100\n"
"101\n"
"110\n"
"115\n"
"120\n"
"125\n"
"127\n"
"135\n"
"139\n"
"141\n"
"201\n"
"222\n"
"230\n"
"245\n"
"247\n"
"250\n"
"254 sgnlfsf\n"
"2340\n"
"345\n"
"255\n"
"853\n"
"999")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.