const regex = /^\s*(?<name>[^|]+?)\s*\|\s*(?<value>[^|]+?)\s*\|\s*(?<unit>[^|]+?)\s*\|\s*(?<status>[^|]+?)\s*\|\s*(?<type>[^|]+?)\s*\|\s*(?<state>[^|]+?)\s*\|\s*(?<lower_nonrec>[^|]+?)\s*\|\s*(?<lower_crit>[^|]+?)\s*\|\s*(?<lower_noncrit>[^|]+?)\s*\|\s*(?<upper_crit>[^|]+?)\s*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s*(?<name>[^|]+?)\\s*\\|\\s*(?<value>[^|]+?)\\s*\\|\\s*(?<unit>[^|]+?)\\s*\\|\\s*(?<status>[^|]+?)\\s*\\|\\s*(?<type>[^|]+?)\\s*\\|\\s*(?<state>[^|]+?)\\s*\\|\\s*(?<lower_nonrec>[^|]+?)\\s*\\|\\s*(?<lower_crit>[^|]+?)\\s*\\|\\s*(?<lower_noncrit>[^|]+?)\\s*\\|\\s*(?<upper_crit>[^|]+?)\\s*$', 'gm')
const str = `CPU1 Temp | 0x0 | discrete | 0x0000| na | na | na | na | na | na
CPU2 Temp | 0x0 | discrete | 0x0000| na | na | na | na | na | na
System Temp | 35,000 | degrees C | ok | -9,000 | -7,000 | -5,000 | 75,000 | 77,000 | 79,000
CPU1 Vcore | 1,200 | Volts | ok | 0,656 | 0,664 | 0,672 | 1,352 | 1,360 | 1,368
CPU2 Vcore | 0,936 | Volts | ok | 0,656 | 0,664 | 0,672 | 1,352 | 1,360 | 1,368
CPU1 DIMM | 1,520 | Volts | ok | 1,184 | 1,192 | 1,200 | 1,648 | 1,656 | 1,664
CPU2 DIMM | 1,520 | Volts | ok | 1,184 | 1,192 | 1,200 | 1,648 | 1,656 | 1,664
+1.5V | 1,504 | Volts | ok | 1,320 | 1,328 | 1,336 | 1,656 | 1,664 | 1,672
+3.3V | 3,240 | Volts | ok | 2,880 | 2,904 | 2,928 | 3,648 | 3,672 | 3,696
+3.3VSB | 3,216 | Volts | ok | 2,880 | 2,904 | 2,928 | 3,648 | 3,672 | 3,696
+5V | 5,056 | Volts | ok | 4,416 | 4,448 | 4,480 | 5,536 | 5,568 | 5,600
+12V | 12,137 | Volts | ok | 10,600 | 10,653 | 10,706 | 13,250 | 13,303 | 13,356
VBAT | 3,192 | Volts | ok | 2,880 | 2,904 | 2,928 | 3,648 | 3,672 | 3,696
Fan1 | na | RPM | na | 405,000 | 540,000 | 675,000 | 34155,000 | 34290,000 | 34425,000
Fan2 | na | RPM | na | 405,000 | 540,000 | 675,000 | 34155,000 | 34290,000 | 34425,000
Fan3 | na | RPM | na | 405,000 | 540,000 | 675,000 | 34155,000 | 34290,000 | 34425,000
Fan4 | na | RPM | na | 405,000 | 540,000 | 675,000 | 34155,000 | 34290,000 | 34425,000
Fan5 | na | RPM | na | 405,000 | 540,000 | 675,000 | 34155,000 | 34290,000 | 34425,000
Fan6 | na | RPM | na | 405,000 | 540,000 | 675,000 | 34155,000 | 34290,000 | 34425,000
Fan7 | na | RPM | na | 405,000 | 540,000 | 675,000 | 34155,000 | 34290,000 | 34425,000
Fan8 | na | RPM | na | 405,000 | 540,000 | 675,000 | 34155,000 | 34290,000 | 34425,000
P1-DIMM1A Temp | 27,000 | degrees C | ok | -9,000 | -7,000 | -5,000 | 80,000 | 85,000 | 90,000
P1-DIMM1B Temp | 26,000 | degrees C | ok | -9,000 | -7,000 | -5,000 | 80,000 | 85,000 | 90,000
P1-DIMM2A Temp | 28,000 | degrees C | ok | -9,000 | -7,000 | -5,000 | 80,000 | 85,000 | 90,000
P1-DIMM2B Temp | 28,000 | degrees C | ok | -9,000 | -7,000 | -5,000 | 80,000 | 85,000 | 90,000
P1-DIMM3A Temp | 29,000 | degrees C | ok | -9,000 | -7,000 | -5,000 | 80,000 | 85,000 | 90,000
P1-DIMM3B Temp | 29,000 | degrees C | ok | -9,000 | -7,000 | -5,000 | 80,000 | 85,000 | 90,000
P2-DIMM1A Temp | 27,000 | degrees C | ok | -9,000 | -7,000 | -5,000 | 80,000 | 85,000 | 90,000
P2-DIMM1B Temp | 26,000 | degrees C | ok | -9,000 | -7,000 | -5,000 | 80,000 | 85,000 | 90,000
P2-DIMM2A Temp | 28,000 | degrees C | ok | -9,000 | -7,000 | -5,000 | 80,000 | 85,000 | 90,000
P2-DIMM2B Temp | 28,000 | degrees C | ok | -9,000 | -7,000 | -5,000 | 80,000 | 85,000 | 90,000
P2-DIMM3A Temp | 29,000 | degrees C | ok | -9,000 | -7,000 | -5,000 | 80,000 | 85,000 | 90,000
P2-DIMM3B Temp | 29,000 | degrees C | ok | -9,000 | -7,000 | -5,000 | 80,000 | 85,000 | 90,000
Intrusion | 0x1 | discrete | 0x0100| na | na | na | na | na | na
PS Status | 0x1 | discrete | 0x0100| na | na | na | na | na | na `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}