re = /^(?=.*[a-zA-Z].*)([-a-zA-Z0-9\s_@#$%^&()!?;:,.^*]+)$/m
str = '_@#$%^&(A)^*!?,.:;'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end