$re = '/^[1]{1}[7-9]{1}\d{6}$|^[2]{1}[0-2]{1}\d{6}$/mi';
$str = '17254354
23464515
16434553
13462164
12564562
22346612
18613232
19561322
20351615
21561321
11326562
10320132';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);