package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:(?<domain>[\w\-]+?)\.(?<parent>[\w\-\.]+)\s*$)`)
var str = `boa.midlandls.commloanservices.com
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}