$re = '/[\p{L}|\p{N}|\s]/u';
$str = 'Hello Привет 你好 123_456 "Âlvarö';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);