package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\s*([a-z]{2})(?:-[A-Z]{2})?(?:\s*;q=([0-9]\.[0-9]))?(?:\s*,|$)`)
var str = `cs-CZ,en-US;q=0.8,sk-SK;q=0.6`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}