package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)([0-9]{12}) AAXX \d{5} ([/|\d]{5}) [/|\d]{5} ([/|\d]{1})([/|\d]{2})([/|\d]{2})( (1[/\d]*)|)( (2[/\d]*)|)(\s*(3[/\d]*)|)(\s*(4[/\d]*)|)(\s*(5[/\d]*)|)(\s*(6[/\d]*)|)(\s*(7[/\d]*)|)(\s*(8[/\d]*)|)\s*333\s*`)
var str = `
##########################################################
# Query made at 11/09/2018 18:33:45 UTC
##########################################################
##########################################################
# latest SYNOP reports from United Kingdom before 11/09/2018 18:33:45 UTC
##########################################################
201811091800 AAXX 09184 03002 15461 /1430 10096 20070 30018 40036 56021 60002 333 10102 82/19 86/28 91041 90710 91141==
201811091800 AAXX 09184 03005 15460 /1431 10090 20061 39920 40019 56025 60002
333 10096 55300 20000 87/14 90710 91142==
201811091800 AAXX 09184 03008 17459 /1327 10097 20074 39923 49995 57027 60002 704//
333 10102 87/14 90710 91142 91041
555 7/097=
201811091800 AAXX 09184 03010 46/// /1344 10108 20074 49900 57035
333 90710 91154==
201811091800 AAXX 09184 03017 15461 /1329 10100 20072 39922 49953 58037 69902
333 10107 55300 20000 83/18 87/39 91039 90710
91141==
201811091800 AAXX 09184 03026 15771 /1233 10111 20066 39814 49832 58047 69982
333 10114 55300 20000 88/50 90710 91141==
201811091800 AAXX 09184 03031 15580 /1219 10085 20052 39556 49873 57042 69902
333 10087 55300 20000 88/22 90710 91129==
201811091800 AAXX 09184 03034 15684 /1220 10119 20052 39832 49845 57049 69902
333 10122 86/43 85/63 90710 91130==
201811091800 AAXX 09184 03039 46/// /1048 10057 20049
333 10058 91071 90710 91171==
201811091800 AAXX 09184 03044 15573 /1030 10098 20063 39794 49890 58039 60002
333 10105 55300 20000 82/23 91043 90710 91150==
201811091800 AAXX 09184 03047 17471 /1422 10085 20058 39572 49865 58049 60032 781//
333 10090 553// 20000 87/18 85/25 91040 90710
91140==
201811091600 AAXX 09164 03062 45575 /1424 10105 20065 39921 49926 58044
333 553// 20119 85/28 90710 91138==
201811091800 AAXX 09184 03063 15580 /1512 10103 20053 39629 49898 56041 69902
333 10106 55300 20000 86/25 86/31 90710 91125==
201811091800 AAXX 09184 03065 46/// /1491 10017 20017
333 10018 91099 00101 90710 91199 00108==
201811091800 AAXX 09184 03066 17581 /1322 10113 20067 39899 49905 56044 69902 723//
333 10115 55300 20000 85/24 86/31 91033 90710
91133==
201811091800 AAXX 09184 03068 12580 81323 10107 20069 39904 49913 58042 60002 885//
333 10113 84620 87630==
201811091800 AAXX 09184 03072 46/// /1458 10037 20037
333 10037 91079 90710 91179==
201811091800 AAXX 09184 03075 15459 /1230 10103 20073 39889 49932 56042 69902
333 10106 84/16 86/24 91044 90710 91144==
201811091800 AAXX 09184 03080 15463 /1319 10095 20076 39758 49925 56045 69902
333 10096 88/10 90710 91137==
201811091800 AAXX 09184 03088 17361 /1535 10096 20084 39770 49929 58049 60002 704//
333 10097 553// 20000 88/07 91048 90710 91148==
201811091800 AAXX 09184 03091 15461 /1519 10101 20079 39863 49940 57045 60002
333 10106 55300 20000 87/12 86/19 91037 90710
91137==
201811091800 AAXX 09184 03100 17537 /1338 10097 20083 39779 49795 56045 60082 761//
333 10114 55300 20000 81/21 86/37 91048 90710
91152==
201811091800 AAXX 09184 03105 17661 /1335 10098 20080 39779 49796 56056 60062 761//
333 10116 86/38 83/50 91048 90710 91148==
201811091800 AAXX 09184 03111 16450 /1334 10098 20085 39800 49812 56054 60192
333 10110 81/13 86/45 91045 90710 91148==
201811091800 AAXX 09184 03132 17642 /1230 10101 20089 39827 49840 56053 60082 762//
333 10113 85/38 85/46 91040 90710 91140==
201811091800 AAXX 09184 03134 17580 /1317 10100 20072 39797 49867 56045 60012 723//
333 10102 55300 20000 82/20 83/26 86/60 90710
91126==
201811091800 AAXX 09184 03136 17571 /1421 10113 20073 39824 49856 56045 69962 781//
333 10116 55300 20000 81/27 84/45 85/60 90710
91131==
201811091800 AAXX 09184 03144 15580 /1011 10103 20066 39858 49899 56044 69922
333 10113 553// 20000 88/20 91021 90710 91127==
201811091800 AAXX 09184 03148 46/// /1335 10053 20051
333 10058 91048 90710 91150==
201811091800 AAXX 09184 03153 17557 /1427 10097 20081 39732 49866 56046 69942 782//
333 10108 55300 20000 82/33 87/47 91038 90710
91141==
201811091500 AAXX 09154 03155 46482 /1521 10091 20061 39633 49923 58049
333 86/18 85/23 91031 90710 91137==
201811091800 AAXX 09184 03158 15470 /1316 10096 20074 39781 49914 56051 60002
333 10108 55300 20000 88/12==
201811091800 AAXX 09184 03162 17480 /1415 10089 20069 39621 49899 56047 69902 723//
333 10090 55300 20000 87/10 84/20 91025 90710
91125==
201811091800 AAXX 09184 03166 17466 /1114 10100 20074 39827 49895 58046 69902 757//
333 10115 55300 20000 87/18 90710 91130==
201811091800 AAXX 09184 03171 15460 /1420 10105 20084 39906 49918 56042 60002
333 10105 55300 20000 88/12 90710 91132==
201811091800 AAXX 09184 03204 11450 81331 10101 20086 39824 49843 56059 60072 76362 885//
333 10117 55300 20000 81713 88628 91041 90710
91141==
201811091800 AAXX 09184 03210 16541 /1433 10093 20075 39724 49871 56045 69982
333 10108 81/29 87/44 91048 90710 91148==
201811091800 AAXX 09184 03212 17562 /1313 10105 20073 39796 49892 57046 69902 781//
333 10120 83/20 84/24 86/31 91023 90710 91128==
201811091800 AAXX 09184 03214 17758 /1322 10100 20080 39870 49888 58044 69982 782//
333 10118 86/50 84/58 90710 91135==
201811091800 AAXX 09184 03220 16984 ///// 10112 20076 39865 49898 56047 60002
333 10112 87/61==
201811091800 AAXX 09184 03224 15268 /1422 10084 20072 39571 49907 56052 60002
333 10084 81/04 87/62 90710 91131==
201811091800 AAXX 09184 03225 16583 /1719 10096 20057 39607 49903 58048 60002
333 10097 55300 20000 81/21 84/38 85/60 90710
91134==
201811091800 AAXX 09184 03226 15584 /1621 10092 20063 39642 49910 57047 60002
333 10094 81/27 84/61 90710 91129==
201811091800 AAXX 09184 03227 46/// /1741 10043 20043
333 10050 91051 90710 91152==
201811091800 AAXX 09184 03230 16358 /1415 10087 20078 39670 49921 56050 60002
333 10088 88/07 90710 91127==
201811091800 AAXX 09184 03238 15467 /1610 10099 20081 39754 49922 56049 60002
333 10099 88/10 91021==
201811091800 AAXX 09184 03240 17359 /1322 10102 20089 39907 49934 56049 60002 704//
333 10103 55300 20000 81/09 86/14 85/50 90710
91132==
201811091800 AAXX 09184 03257 15471 /1514 10105 20086 39896 49935 57045 69902
333 10106 55300 20000 83/12 85/63 90710 91127==
201811091800 AAXX 09184 03265 17981 /1420 10104 20087 39911 49941 57042 69902 722//
333 10106 83/62 84/65 85/69 90710 91129==
201811091800 AAXX 09184 03266 16969 /1515 10108 20080 39927 49944 56041 69902
333 10109 84/63 91025 90710 91125==
201811091800 AAXX 09184 03275 17471 /1525 10098 20084 39758 49946 56042 69902 723//
333 10104 84/11 86/35 90710 91134==
201811091800 AAXX 09184 03281 16/// /1618 10087 20081 69922
333 10101 90710 91127==
201811091800 AAXX 09184 03292 169// /1625 10108 20092 39947 49965 56033 60002
333 10118 90710 91132==
201811091800 AAXX 09184 03301 16556 /1725 10103 20084 39771 49842 56066 60032
333 10127 82/32 87/50 90710 91141==
201811091800 AAXX 09184 03302 17550 /1533 10108 20089 39822 49835 56062 60032 782//
333 10127 55300 20000 82/28 87/48 91043 90710
91149==
201811091800 AAXX 09184 03305 17556 /2516 10097 20073 39616 49869 56053 60082 762//
333 10115 83/21 87/27 91037 90710 91144==
201811091800 AAXX 09184 03313 16861 /1415 10101 20081 39775 49866 57064 60012
333 10115 87/57 91029 90710 91129==
201811091800 AAXX 09184 03316 17669 /1320 10117 20071 39875 49885 58055 69902 757//
333 10122 83/37 87/57 91033 90710 91133==
201811091800 AAXX 09184 03318 16/// /1321 10105 20072 69942
333 10118 90710 91130==
201811091800 AAXX 09184 03321 17564 /1522 10113 20077 39879 49891 56054 69902 762//
333 10120 55300 20000 87/28 84/37 91032 90710
91132==
201811091800 AAXX 09184 03330 17580 /1516 10087 20062 39576 49928 58041 69922 781//
333 10095 86/20 83/61 91026 90710 91129==
201811091800 AAXX 09184 03344 15581 /1514 10086 20071 39618 49928 58043 69942
333 10090 81/21 87/61 91024==
201811091800 AAXX 09184 03346 16/// /1421 10084 20063 69942
333 10088 90710 91129==
201811091800 AAXX 09184 03351 165// /1619 10109 20070 39870 49911 58046 69922
333 10118 55300 20000 82/33 87/50 90710 91127==
201811091800 AAXX 09184 03354 15676 /1515 10104 20063 39815 49955 58032 69922
333 10109 55300 20000 84/49 87/62 91029 90710
91129==
201811091800 AAXX 09184 03373 16981 /1613 10099 20074 39898 49967 58026 60002
333 10109 82/64 83/72==
201811091800 AAXX 09184 03377 11/80 71516 10097 20073 39889 49971 58025 69902 70252 83072
333 10108 55300 20000 83364 87075==
201811091800 AAXX 09184 03379 16979 /1418 10096 20069 39896 49972 58026 69902
333 10109 85/64 85/69==
201811091800 AAXX 09184 03382 15980 /1512 10108 20078 39954 49963 56036 69902
333 10117 55300 20000 82/71==
201811091800 AAXX 09184 03385 46980 /1514 10101 20083 39971 49981 56029
333 10119 85/71==
201811091800 AAXX 09184 03391 11/81 71614 10104 20076 39972 49979 58024 69902 70262 85076
333 10116 85364 87270==
201811091800 AAXX 09184 03392 16973 /1622 10107 20085 39985 49989 58023 60002
333 10122 84/70 90710 91127==
201811091800 AAXX 09184 03405 16350 /1534 10097 20089 39731 49844 56056 60062
333 10109 55300 20000 81/09 86/17 85/38 91048
90710 91149==
201811091800 AAXX 09184 03409 16/// /1411 10098 20073 39682 49876 56058 60072
333 10114 55300 91024 90710 91129==
201811091700 AAXX 09174 03410 46468 /1413 10083 20065 39476 49899 58055
333 55300 20000 87/17 84/26 91025 90710 91130==
201811091800 AAXX 09184 03414 17564 /1520 10111 20078 39821 49907 56049 69902 781//
333 10118 55300 20000 87/29 91032 90710 91133==
201811091800 AAXX 09184 03462 15975 /1514 10105 20065 39885 49972 58026 69902
333 10116 55300 20000 87/63 85/67 85/71==
201811091800 AAXX 09184 03469 15981 /1615 10104 20080 39985 49989 58020 69902
333 10120 553// 20000 86/69==
201811091800 AAXX 09184 03482 15976 /1616 10110 20069 39978 40003 58016 60002
333 10126 87/70==
201811091800 AAXX 09184 03488 15981 /1615 10106 20085 39982 40008 56021 60002
333 10136 55300==
201811091800 AAXX 09184 03502 17450 /1526 10094 20094 39692 49849 55043 60112 762//
333 10109 55300 20000 82/10 86/32 91036 90710
91148==
201811091600 AAXX 09164 03503 47768 /1516 10106 20077 39824 49898 56065 781//
333 87/50 91027 90710 91132==
201811091800 AAXX 09184 03507 17426 /1726 10088 20080 39521 49882 57052 60072 763//
333 10103 86/11 84/36 91037 90710 91141==
201811091800 AAXX 09184 03520 16467 /1612 10104 20087 39794 49912 57048 60022
333 10119 55300 20000 82/16 87/22 91022 90710
91127==
201811091800 AAXX 09184 03522 17460 /1410 10104 20090 39826 49916 57049 60032 762//
333 10122 81/16 86/19 91021==
201811091800 AAXX 09184 03529 17562 /1519 10112 20081 39896 49938 58044 69922 782//
333 10127 83/28 86/33 90710 91128==
201811091800 AAXX 09184 03535 17564 /1515 10108 20073 39824 49938 57044 69982 781//
333 10116 553// 20000 84/28 85/36 91026 90710
91129==
201811091800 AAXX 09184 03544 15581 /1610 10110 20071 39826 49953 57039 69922
333 10119 553// 20000 86/31 84/38 91021 90710
91125==
201811091800 AAXX 09184 03560 15982 /1617 10105 20069 39877 49978 58032 69942
333 10122 553// 20000 87/61 86/68 90710 91127==
201811091800 AAXX 09184 03590 15977 /1712 10103 20070 39910 40018 58017 69922
333 10121 55300 20000 87/69==
201811091800 AAXX 09184 03604 16231 /1726 10122 20117 39793 49844 56039 60132
333 10124 82/06 85/16 91036 90710 91146==
201811091800 AAXX 09184 03605 16418 /1737 10113 20105 39865 49873 56045 60122
333 10127 86/11 84/19 91047 90710 91147==
201811091800 AAXX 09184 03609 16/// /1631 10126 20102 39832 49883 56055 60082
333 10130 91045 90710 91147==
201811091800 AAXX 09184 03647 16580 /1724 10100 20069 39697 49945 58041 60012
333 10110 553// 20000 85/23 86/30 90710 91132==
201811091800 AAXX 09184 03649 11575 81715 10114 20071 39857 49955 58040 60012 76062 8652/
333 10125 55300 86630 87458 91026 90710 91126==
201811091800 AAXX 09184 03658 16681 /1523 10121 20065 39900 49968 56039 69902
333 10129 87/40 85/64 91033 90710 91136==
201811091800 AAXX 09184 03660 15676 /1613 10105 20063 39734 49976 56037 69922
333 10121 85/35 87/64 90710 91128==
201811091800 AAXX 09184 03672 11681 81615 10122 20063 39948 49987 58035 69922 70361 8152/
333 10141 81635 87466==
201811091800 AAXX 09184 03680 16/// ///// 10109 20062 39834 49986 58032 69942
333 10122 553// 20000==
201811091800 AAXX 09184 03684 15981 /1512 10103 20069 39903 40007 58020 69922
333 10125 86/65==
201811091800 AAXX 09184 03693 15981 /1814 10113 20071 30018 40020 58021 69902
333 10130 55300 86/67==
201811091800 AAXX 09184 03707 17545 /1522 10116 20102 39881 49888 56046 60052 762//
333 10129 83/20 86/26 90710 91136==
201811091800 AAXX 09184 03710 16118 /1724 10088 20088 39492 49900 56049 60062
333 10096 55300 20000 87/03 86/10 91042 90710
91145==
201811091800 AAXX 09184 03716 17456 /1521 10114 20097 39838 49896 56056 60012 762//
333 10124 55300 20000 87/14 83/56 91035 90710
91137==
201811091800 AAXX 09184 03743 16447 /1613 10099 20084 39801 49958 56041 60022
333 10128 81/16 84/27 86/31 90710 91126==
201811091800 AAXX 09184 03746 17450 /1620 10099 20085 39812 49962 56041 60032 762//
333 10131 82/15 84/23 87/30 90710 91134==
201811091800 AAXX 09184 03749 16557 /1722 10106 20083 39857 49965 57040 60022
333 10134 87/27 84/42 90710 91135==
201811091800 AAXX 09184 03761 17663 /1621 10112 20073 39838 49978 57039 60012 781//
333 10128 55300 20000 81/39 85/47 91031 90710
91131==
201811091800 AAXX 09184 03768 16680 /1516 10123 20067 39905 49982 58038 69922
333 10134 81/39 84/49 86/66 90710 91126==
201811091800 AAXX 09184 03769 15675 /1712 10117 20067 39917 49997 58037 69982
333 10128 55300 20000 81/35 87/67==
201811091700 AAXX 09174 03770 46/// ///// 10119 20070==
201811091800 AAXX 09184 03772 15980 /1517 10120 20065 39959 49989 58035 69922
333 10141 55300 20000 88/67 90710 91125==
201811091800 AAXX 09184 03781 15981 /1611 10106 20064 39796 49998 58034 69962
333 10120 553// 20000 85/66 91021==
201811091800 AAXX 09184 03796 46/// /1818 10121 20086 39895 40034 58019
333 10129 91031 90710 91132==
201811091800 AAXX 09184 03797 15981 /1716 10118 20077 39975 40034 57022 60002
333 10131 55300 20000 87/69==
201811091800 AAXX 09184 03803 17758 /2324 10136 20134 39840 49876 53014 60102 723//
333 10137 83/50 90710 91130==
201811091800 AAXX 09184 03808 11250 82011 10119 20114 39772 49875 55022 60222 76062 885//
333 10131 55300 20000 82706 88657 90710 91129==
201811091800 AAXX 09184 03809 16463 /2116 10118 20114 39793 49882 55021 60142
333 10129 81/14 86/44 90710 91141==
201811091500 AAXX 09154 03823 47232 /1624 10099 20097 39689 49926 58059 762//
333 553// 20047 85/04 87/13 91044 90710 91144==
201811091600 AAXX 09164 03827 47420 /1627 10110 20102 39869 49930 58060 763//
333 83/12 84/20 86/23 91042 90710 91143==
201811091800 AAXX 09184 03840 17213 /1726 10096 20095 39619 49916 56049 60132 762//
333 10113 85/04 84/11 91045 90710 91148==
201811091800 AAXX 09184 03853 17456 /1626 10110 20096 39908 49931 56049 60052 762//
333 10131 55300 20000 82/15 86/25 90710 91139==
201811091800 AAXX 09184 03857 17521 /1638 10113 20106 39879 49941 58055 60052 762//
333 10136 87/20 91050 90710 91150==
201811091800 AAXX 09184 03862 17547 /1723 10111 20089 39952 49964 56043 60042 762//
333 10140 55300 20000 83/27 87/38 91038 90710
91139==
201811091800 AAXX 09184 03866 16/// /1921 10120 20081 39956 49980 56041 60012
333 10137 91034 90710 91135==
201811091800 AAXX 09184 03872 17658 /2024 10120 20092 39984 49989 58037 69942 781//
333 10138 553// 20000 84/34 84/47 91035 90710
91135==
201811091800 AAXX 09184 03876 16/// /1624 10136 20084 30000 40003 57037 69922
333 10139 91035 90710 91135==
201811091800 AAXX 09184 03882 15971 /1910 10120 20079 39958 40020 56028 69962
333 10135 55300 20000 88/68 90710 91125==
201811091800 AAXX 09184 03894 11458 81733 10107 20096 49964 57044 60042 76362 885//
333 10134 81614 83615 87620 91046 90710 91147==
201811091800 AAXX 09184 03895 17556 /1730 10109 20088 39882 49984 57039 60052 761//
333 10132 55300 20000 82/24 84/31 85/57 91045
90710 91147==
201811091800 AAXX 09184 03901 17784 /1509 10077 20069 39679 49764 55013 60162 723//
333 10102 55300 20000 87/50 90710 91131==
201811091800 AAXX 09184 03904 17762 /1511 10093 20079 39696 49754 56033 60152 782//
333 10107 87/50 90710 91126==
201811091600 AAXX 09164 03907 47757 /1430 10098 20082 39789 49796 56073 762//
333 55300 20018 87/50 91045 90710 91152==
201811091800 AAXX 09184 03915 17434 /1330 10100 20092 39703 49778 56054 60132 762//
333 10107 81/16 83/29 85/43 91050 90710 91150==
201811091800 AAXX 09184 03916 17230 /1720 10088 20083 39619 49802 56045 60122 763//
333 10105 553// 20000 85/06 86/15 91039 90710
91146==
201811091800 AAXX 09184 03917 17432 /1422 10099 20089 39721 49795 56048 60132 763//
333 10111 55300 20000 81/11 86/41 91032 90710
91141==
201811091800 AAXX 09184 03923 17356 /1824 10098 20094 39590 49778 56043 60252 762//
333 10100 82/08 86/42 91036 90710 91146==
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}