re = /^[0-9A-F]{8}-[0-9A-F]{4}-4[0-9A-F]{3}-[89AB][0-9A-F]{3}-[0-9A-F]{12}$/i
str = 'ad7e47a1-15a1-44f8-b4cb-924b02e1cc89'
# Print the match result
str.match(re) do |match|
puts match.to_s
end