$re = '/<!--([\w\W]+)-->([\w\W]*)<!--\s?\/\1-->/m';
$str = '<!-- block -->
My content
<!-- / block -->
<!-- empty --><!-- / empty -->
<!-- inline -->My content<!-- / inline -->
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);