const regex = /(--([A-z\-]*?):(?<!--rgb:)).*?;/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(--([A-z\\-]*?):(?<!--rgb:)).*?;', 'gm')
const str = ` --color-primary: #0017a8;
--color-primary--rgb: #{hexToRGB(color-primary)};
--variablename: blabla blablabla;
--color-secondary: #0631ff;
--color-secondary--rgb: #{hexToRGB(color-secondary)};
--color-tertiary: #00ffe0;
--color-tertiary--rgb: #{hexToRGB(color-tertiary)};
--color-green-dark: #257426;
--color-green-dark--rgb: #{hexToRGB(color-green-dark)};
--font-family: TTCommons, Helvetica, Arial, sans-serif;
--transition: 0.3s ease;
--box-shadow: 0 0 12px 0 rgba(0, 0, 0, 0.3);`;
const subst = `$1 #{$$$2};`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);