re = /(?<=<p>).*?(?=<\/p>)/
str = '<p>Hello !</p> <p>I wont select tags! Only text with in</p>
<p>Hello !</p> <p>I wont select tags! Only text with in</p>
<p>Hello !</p> <p>I wont select tags! Only text with in</p>
<p>Hello !</p> <p>I wont select tags! Only text with in</p>'
subst = 'replace me'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result