import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<userConfiguration\\s*id=(?<Id>[.]|[^<]*)>\\s*<user\\s*FullName=\\\"(?<FullName>[.]|[^\\\"]*)\\\"\\s*LoginName=\\\"(?<LoginName>[.]|[^\\\"]*)\\\"\\s*Group=\\\"(?<Group>\\d{1,3})";
final String string = "<userConfiguration id=\"myId\">\n"
+ " <user FullName=\"\" LoginName=\"User-1-LoginName\" Group=\"0\" Level=\"0\" StartingDate=\"2020-08-04\" ExpiredDate=\"2021-02-05\" salt=\"4Bn0RL/qMZeBFIck+o+oHCVLtRwJzgxN4tAUV4zhCUMZSVNpdhkgguPuLCt4/k4L\" data=\"dXBIUUqmYsJ5llcDKHGbYahM8YETEpkx31n+ridQKZD6QtxtuBtgsD6+kkI0YGRleV17O3aN4ieCCjJ3l1IdEOvD4jjb8NTFCr4vXZHh2K+hhl9LyisKopbkNbo6ExHC4f1RC4RNJDTcHrTp7SqetpSYzvQ/Tn8/0r/PLGlbOn2ihbTtZkC+r4QSKjAtE21sB0bvBrCd8yyI37vbLqfJrXs0mVyll63AdNcfzNWoMETNEIZWGiWyRw+nOlC8gA3ag4909dR6rk7vX3lBSNgUBwegcTeJyznpZLq5yppj5vTQe0kZZbbfxuFcDEktyH4O\"/>\n"
+ " <encodedData><![CDATA[[header]\n"
+ "Description=User Configuration file for WTT_ENC\n"
+ "Version=4\n"
+ "User=eckrodt\n"
+ "Timestamp=05.08.2020 13:42:48\n"
+ "Tool=M1ServiceCenter\n"
+ "LicenseOption=1\n"
+ "[body]\n"
+ "IZ4J7wFwyNRZn9syvJSQhJFo8Oipq15O4Ybe5a/sv65uqXI3d6lDY1rb5IrtF/r95PegytemC+6lxuQxwptSjKF2gRUZB3vN\n"
+ "Q8HXbP3OWh2gImJHjc6Yz+Tw6f+D+Herq/Plr6LMh2in1mKfiuof]]></encodedData>\n"
+ "</userConfiguration>\n\n"
+ "<userConfiguration\\s*id=(?<Id>[.]|[^<]*)>\\s*<user\\s*FullName=\\\"(?<FullName>[.]|[^\\\"]*)\\\"\\s*LoginName=\\\"(?<LoginName>[.]|[^\\\"]*)\\\"\\s*Group=\\\"(?<Group>\\d{1,3})";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}