use strict;
my $str = '/**
* bla bla
*bla2 @ bla2 @
*
* bla bla 3
*
* @olivier voila
* @param string $sku1 bidule
*
* @param string[] $sku2
*
* @param string $sku3 toto bidule @
* machin truc
*
* @param string $sku4
* machin truc
*
* @deprecated
*
* @deprecated toto
*
* @throws Exception
* @throws Exception
* machin
* @return Cfe_Type_Product
* @cache 3600
* @roles toto, titi,truc , machin
*/';
my $regex = qr~(?<=^|\v)
\h*+\*\h*+
(?:
(?:
(?P<annotation>
@(?P<name>\w++)
(?:
(?<=@param)\h++(?P<type>\w++(?:\[\])?)\h++\$(?P<variable>\w++)
|(?<=@return)\h++(?P<type>\w++(?:\[\])?)
|(?<=@throws)\h++(?P<class>\w++)
|(?<=@cache)\h++(?P<time>\d++)
|(?<=@roles)\h++(?P<roles>\w++(?:\h*+,\h*+\w++)*)
)?
)
)
(?P<comment>\h++[^\v]++)?
(?:(?P<comment>\v)\h*+\*\h*+(?P<comment>[^\v@\h\*][^\v]++))*+
|(?P<description>(?:[^\v@\h\*][^\v]++)
(?:
\v\h*+\*\h*+[^\v@\h\*][^\v]++
)*+
)
) ~xsp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}