re = /(^100(\.0{1,2})?$)|(^([1-9]([0-9])?|0)(\.[0-9]{1,2})?$)/
str = '1234232342'
# Print the match result
str.match(re) do |match|
puts match.to_s
end