using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<src_host>\w+\.\w+:\d{2})\s(?<src_ip>\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})\D{1,6}(?<date_time>[^ ]+)\s(?<GMT_offset>[^ ]+)\]\s""(?<action>(GET|POST|HEAD|TRACE|PUT|DELETE|CONNECT))\s(?<hash_url>[^ ]+)\s(?<protocol>[^\""]+)\""\s(?<code>\d{1,3})\s(?<size>[^ ]+)\s\""(?<referrer>[^ ]+)\""\s\""(?<user_agent>[^ ]+.+)\""";
string input = @"google.com:80 212.111.203.171 - - [02/Mar/2015:10:27:04 +0000] ""GET /css/style.css HTTP/1.1"" 304 138 ""http://google.com"" ""Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/40.0.2214.115 Safari/537.36""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}