use strict;
my $str = '165.72.104.6 - admin 12/May/2021:09:37:52 +0000 "GET /etc/clientlibs/website/global/public/img/loading.gif HTTP/1.1" 200 17585 "https://my.domain.com/etc/clientlibs/website/global/public/stylesheets/project-base.108cb261dae9b1ccd0121c7571bbd42f2fc6d0a78a9bffb03b16be08753a32ad.css" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/90.0.4430.212 Safari/537.36"';
my $regex = qr/(?P<req_ip>^[\d\.]+)\s+(?P<req_identity>.+?)\s+(?P<req_user>.+?)\s+(?P<req_date>.+?)\s+(?P<req_offset>.+?)\s+"(?P<req_method>.+?)\s+(?P<req_path>.+?)\s+(?P<req_protocoll>.+?)"\s+(?P<req_code>.+?)\s+(?P<req_size>.+?)\s+"(?P<req_referer>.+?)"\s+"(?P<req_device>.+?)"/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}