$re = '/^[a-f0-9]{32}$/i';
$str = 'e10adc3949ba59abbe56e057f20f8832';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);