# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:\S+\s){27,27}(?:status:\s+(?<status>\d+))?"
test_str = ("Property(S): PrimaryVolumeSpaceAvailable = 0\n"
"Property(S): PrimaryVolumeSpaceRequired = 0\n"
"Property(S): PrimaryVolumeSpaceRemaining = 0\n"
"Property(S): ProductToBeRegistered = 1\n"
"MSI (s) (24:7C) [21:56:44:998]: Note: 1: 1707 \n"
"MSI (s) (24:7C) [21:56:44:998]: Product: VetLab Station -- Installation operation completed successfully.\n\n"
"MSI (s) (24:7C) [21:56:45:001]: Windows Installer installed the product. Product Name: VetLab Station. Product Version: 4.35.72. Product Language: 1033. Manufacturer: IDEXX Laboratories, Inc.. Installation success or error status: 0.\n\n"
"MSI (s) (24:7C) [21:56:45:002]: Value of RebootAction property is \n"
"MSI (s) (24:7C) [21:56:45:002]: Windows Installer requires a system restart. Product Name: VetLab Station. Product Version: 4.35.72. Product Language: 1033. Manufacturer: IDEXX Laboratories, Inc.. Type of System Restart: 1. Reason for Restart: 0.")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.