$re = '/^[\d]+$/m';
$str = '100
5
6.3
-1
-5
ac
1a
511213215489756213s
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);