re = /<([^>]+)>([^<]+)<(\/\1)>/
str = '<h1>Nayeem loves counseling</h1>
<h1><h1>Sanjay has no watch</h1></h1><par>So wait for a while<par>
<Amee>safat codes like a ninja</amee>
<SA premium>Imtiaz has a secret crush</SA premium>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end