const regex = new RegExp('^(?:\\"Flesh)|^(?:\\"Primitive)|^(?:\\"Mutant)|^(?:\\"Sacred)|^(?:\\"Super)|^(?:\\"Meat of)', 'gm')
const str = `
"Black beetle killed. No beast soul gained. Eat the flesh of the black beetle to gain zero to ten geno points randomly."
"Black beetle flesh eaten. Zero geno points gained."
"Flesh of black beetle eaten. One sacred geno point gained."
"Flesh of black beetle eaten. One sacred geno point gained."
"Flesh of black beetle eaten. One sacred geno point gained."
"Primitive creature green-scaled beast killed. No beast soul gained. Eat the flesh of the primitive green-scaled beast to gain zero to ten points randomly."
"Primitive creature swift mantis killed. No beast soul gained. Eat the swift mantis to gain zero to ten primitive geno points randomly."
"Primitive creature swift mantis killed. No beast soul gained. Eat the swift mantis to gain zero to ten points randomly."
"Primitive creature swift mantis killed …"
"Primitive creature copper-toothed beast killed. No beast soul gained. Eat the flesh of copper-toothed beast to gain zero to ten primitive geno points randomly."
"Primitive creature copper-toothed beast killed. Primitive beast soul of copper-toothed beast gained. Eat the flesh of copper-toothed beast to gain zero to ten primitive geno points randomly."
"Sacred-blood bloody slayer killed. Sacred-blood beast soul bloody slayer gained. Eat the flesh of bloody slayer to gain zero to ten sacred geno points randomly."
"Primitive green-scaled beast flesh eaten. One primitive geno point gained."
"Mutant copper-toothed beast killed. No beast soul gained. Eat its flesh to gain zero to ten mutant geno points."
"Mutant copper-toothed beast flesh eaten. One mutant geno point gained."
"Primitive creature quartz scorpion killed. No beast soul gain. Eat the flesh of quartz scorpion to gain zero to ten primitive geno points."
"Primitive quartz scorpion flesh eaten. Four primitive geno points gained."
"Young obsidian dragon eaten. One sacred geno point gained…"
"Black beetle killed. No beast soul gained. Eat the flesh of the black beetle to gain zero to ten geno points randomly."
"Black beetle flesh eaten. Zero geno points gained."
"Flesh of black beetle eaten. One sacred geno point gained."
"Flesh of black beetle eaten. One sacred geno point gained."
"Flesh of black beetle eaten. One sacred geno point gained."
"Primitive creature green-scaled beast killed. No beast soul gained. Eat the flesh of the primitive green-scaled beast to gain zero to ten points randomly."
"Primitive creature swift mantis killed. No beast soul gained. Eat the swift mantis to gain zero to ten primitive geno points randomly."
"Primitive creature swift mantis killed. No beast soul gained. Eat the swift mantis to gain zero to ten points randomly."
"Primitive creature swift mantis killed …"
"Primitive creature copper-toothed beast killed. No beast soul gained. Eat the flesh of copper-toothed beast to gain zero to ten primitive geno points randomly."
"Primitive creature copper-toothed beast killed. Primitive beast soul of copper-toothed beast gained. Eat the flesh of copper-toothed beast to gain zero to ten primitive geno points randomly."
"Sacred-blood bloody slayer killed. Sacred-blood beast soul bloody slayer gained. Eat the flesh of bloody slayer to gain zero to ten sacred geno points randomly."
"Primitive green-scaled beast flesh eaten. One primitive geno point gained."
"Mutant copper-toothed beast killed. No beast soul gained. Eat its flesh to gain zero to ten mutant geno points."
"Mutant copper-toothed beast flesh eaten. One mutant geno point gained."
"Primitive creature quartz scorpion killed. No beast soul gain. Eat the flesh of quartz scorpion to gain zero to ten primitive geno points."
"Primitive quartz scorpion flesh eaten. Four primitive geno points gained."
"Young obsidian dragon eaten. One sacred geno point gained…"
"Sacred-blood creature purple-winged dragon killed. Sacred-blood beast soul of purple-winged dragon gained. Eat the flesh of purple-winged dragon to gain zero to ten sacred-blood geno points randomly."
"Sacred-blood copper-toothed beast killed. No beast soul gained. Eat its meat to gain one to ten sacred geno points randomly."
"Meat of copper-toothed beast eaten. One sacred geno point gained."
"Meat of copper-toothed beast eaten. One sacred geno point gained."`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}