$re = '/^P-\d{2}-\d{4}$/';
$str = 'P-11-1111';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);