# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^([-!#$%&'*+\/=?^_`{}|~0-9a-zA-Z]+(\.[-!#$%&'*+\/=?^_`{}|~0-9a-zA-Z]+)*|^"([\001-\010\013\014\016-\037!#-\[\]-\177]|\\[\001-011\013\014\016-\177])*")@(?:[a-zA-Z0-9](?:[a-zA-Z0-9-]{0,61}[a-zA-Z0-9])?\.)+[a-zA-Z]{2,6}\.?$//;t' <<< "da.ni.el@l.ev.ire.cc"