$re = '/a(?>bc|b)c|\b(?>integer|insert|in)\b|\b(integer|insert|in)\b|(?>ta|tala|talala)\b/';
$str = 'Nom : Atomic Group
Description :
1st Alternative (1er regex) :
Test successivement les valeurs comprises dans la liste "Atomic Group" si a est trouvé, on passe au groupe atomique, si bc est trouvé, on passe à c, si c est trouvé, l\'expression match (Exemple 1 voir en bas de page).
Sinon, si a est trouvé, et que bc est trouvé, on cherche donc c, c n\'est pas trouvé, l\'expression ne match pas (Exemple 2).
2nd Alternative (2nd regex) :
Pour notre seconde expressions on à d\'abbord un classique \\b indiquant qu\'on ne veux pas de lettre en première position, puis si integer match, on passe directement à la fin du groupe atomic, sinon, le moteur de regex abandonne la recherche et retourne un échec sans regarder les autres expressions du groupe raison pour laquelle l\'exemple 3 ne matche rien bien qu\'elle contienne l\'expression \'in\' contrairement à l\'exemple 4
3rd Alternative :
Enfin, notre troisième expression va mettre en avant le principe de backtracking, gourmand en ressource et chronophage puisqu\'il va d\'abbord regarder s\'il n\'y à pas une lettre en première position, puis si integer match, il va regarder si l\'on à pas une lettre en dernière position, si l\'on à un lettre en dernière position alors le moteur de regex revient (backtrack) dans le groupe de capture (Capturing Group) pour regarder la seconde alternative, et ainsi de suite il va analyser toutes les alternatives jusqu\'à en trouver une qui matche
4th Alternative :
Le moteur de regex matche ta (Exemple 5) donc il sort du groupe et regarde ce qui est indiqué ensuite : \\b il ne doit pas y avoir de lettre ensuite ors, il y en à une, le \'l\', l\'expression régulière ne matche pas la chaîne rechercher, le moteur de template renvoi un échec
De manière plus consise, le group atomic, s\'arrête dès lors que la première expression du groupe ne match pas, c\'est pourquoi il faut faire attention à l\'ordre dans lequel on saisie les éléments du group atomic en mettant d\'abbord les chaînes les plus longues (voir 2nd Alternative) et non pas les chaînes les plus courtes (4th Alternative)
Atomic group --> après avoir matché l\'un des éléments du groupe, on sort et on ne revient plus en arrière
Capturing group --> On test toutes les alternatives avec autant de retour en arrière (backtracking) que nécessaire jusqu\'à matcher l\'expression ou jusqu\'à l\'échec
Exemple 1 :
abcc
Exemple 2 :
abc
Exemple 3 :
integers
Exemple 4 :
insert
Exemple 5 :
tala
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);