#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(.*[pP].*[uUÜü@].*[bB].*[iIïÏ1|lL].*[|iIïÏ1lL].*[cC].*[|iIïÏ1lL].*[dD].*[aA4äÄ@Ã].*[dD])"
Local $sString = "publicidad"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")