// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)[FHD]?[LP]U?\d{3}|H032B|RVS8N").unwrap();
let string = "BUSS4 Business Flat Line Bundle
FSULR Ftr Simply Unl LD Bundle
CC55P Addl Line Basic 2yr Cred n/a Bundle Discount
FSCC1 Ftr Simply Unl Feat Bundle Discount
WZC21 LD Discount 24 MO Bundle Discount
RE099 Additional Line Credit Discount
RE117 Solutions Bundle Discount Discount
WZ101 Simply Unlimited Term Discount
BLSR1 Business Line - Rotary Feature
CX113 Centranet Feature Package Feature
IWMB7 Inside Wire Maint - Bus Feature
OPSN1 Oprtr Call Scrng Inbound Feature
OVOP4 Onepoint Voice Ma Feature
VDI03 Unlimited Local Toll n/a Toll
VDI04 Unlimited Regional toll c n/a Toll
B1 Business Line
B1FT3 Business Line - 3 Yr Term
B1M Business Line - Metered
CFNT1 CentraNet Stn Ln 2-25
CXAM1 CustoPak Ln Measrd Rate
EUAPB ISDN BRI Interst Acc Port
FEA1P Addl Line Unl 2 Yr Feat
IBCD6 ISDN B Channel Voice & Da
IBRB1 ISDN Single User Access
ISA06 ISDN BRI Access
NP Non-Published Listing
SOLF2 Sol Bun Line 2yr Cpk Feat
SOLF3 Solutions Feat Pack
VLC21 Unlimited Local and ZUM c n/a
WZC70 LEC Discount Bus 24 MO
WZB90 HSI Discount 99 MO Discount
WZB93 FiOS Internet Bus 99 MO Discount
WZC66 HSI Discount 24 MO Discount
MSC03 FiOS Quantum Gateway Rout Equipment
DL658 High Speed Inet - 7.1/768
DP658 High Speed Inet - 7.1/768
FL503 FiOSInet 25M/25M 2YR Loop
FP503 FiOSInet 25M/25M 2YR Port
H032B FiOS Internet
HL384 High Speed Inet - 7.1/768
HP384 High Speed Inet - 7.1/768
LU040 FiOS Internet 25/25 Mb
PU040 FiOS Internet 25/25 Mb
RVS8N Online Bkup & Shrng/50GB
VDO03 Unlimited Long Distance n/a
TTWLD Talk to the World
VDO04 Unlimited long distance c n/a
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}