$re = '/^[0-1]{1}\.?\d{0,8}$|^2{1}\.?0{0,8}$/';
$str = '0.011';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);