import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = " \"name\": \"(.+)\",(.*)|\"endpoint\": \"(.*\\..*)\",";
final String string = "\n"
+ " \"name\": \"Arkane Network\",\n\n\n"
+ " \"endpoint\": \"app.arkane.network \",\n\n"
+ " \"endpoint\": \"connect.arkane.network \",\n\n"
+ " \"endpoint\": \"login.arkane.network\",\n\n\n"
+ " \"name\": \"Bpost2\",\n\n"
+ " \"endpoint\": \"*.bpost2.be\",\n\n"
+ " \"name\": \"Brussels Airlines\",\n\n"
+ " \"endpoint\": \"bprofile.brusselsairlines.com\",\n\n"
+ " \"endpoint\": \"www.brusselsairlines.com\",\n\n"
+ " \"name\": \"De Morgen\",\n\n"
+ " \"endpoint\": \"*.demorgen.be\",\n\n"
+ " \"endpoint\": \"abonnement.demorgen.be\",\n\n"
+ " \"endpoint\": \"login2.demorgen.be\",\n\n"
+ " \"endpoint\": \"myaccount.demorgen.be\",\n\n"
+ " \"endpoint\": \"shop.demorgen.be\",\n\n"
+ " \"endpoint\": \"www.demorgen.be\",\n\n"
+ " \"name\": \"Delen Private Bank\",\n\n"
+ " \"endpoint\": \"api.digital.delen.be \",\n\n"
+ " \"endpoint\": \"api.digital.delen.lu \",\n\n"
+ " \"endpoint\": \"app.delen.be \",\n\n"
+ " \"endpoint\": \"app.delen.ch \",\n\n"
+ " \"endpoint\": \"app.delen.lu \",\n\n"
+ " \"endpoint\": \"auth.digital.delen.be \",\n\n"
+ " \"endpoint\": \"auth.digital.delen.lu \",\n\n"
+ " \"endpoint\": \"be.delen.digital\",\n\n"
+ " \"endpoint\": \"login.delen.be \",\n\n"
+ " \"endpoint\": \"login.delen.ch \",\n\n"
+ " \"endpoint\": \"login.delen.lu \",\n\n"
+ " \"endpoint\": \"login.oyens.com\",\n\n"
+ " \"endpoint\": \"status.delen.be \",\n\n"
+ " \"endpoint\": \"sts.delen.be \",\n\n"
+ " \"endpoint\": \"www.cadelam.be \",\n\n"
+ " \"endpoint\": \"www.cadelux.lu/en \",\n\n"
+ " \"endpoint\": \"www.delen.be/en \",\n\n"
+ " \"name\": \"EURid\",\n\n"
+ " \"endpoint\": \"*.das.eu\",\n\n"
+ " \"endpoint\": \"*.dns.eu\",\n\n"
+ " \"endpoint\": \"*.eurid.eu\",\n\n"
+ " \"endpoint\": \"*.nic.eu\",\n\n"
+ " \"endpoint\": \"*.registry.eu\",\n\n"
+ " \"endpoint\": \"*.whois.eu\",\n\n"
+ " \"name\": \"GULP\",\n\n"
+ " \"endpoint\": \"www.gulp-shop.de\",\n\n"
+ " \"endpoint\": \"*.gulp.ch\",\n\n"
+ " \"endpoint\": \"*.gulp.de\",\n\n"
+ " \"endpoint\": \"demo.tendertracker.de\",\n\n"
+ " \"name\": \"Hardware Info\",\n\n"
+ " \"endpoint\": \" *.hardware.info \",\n\n"
+ " \"endpoint\": \"*.hwigroup.com\",\n\n"
+ " \"endpoint\": \"*.hwigroup.net \",\n\n"
+ " \"name\": \"Hoplr\",\n\n"
+ " \"endpoint\": \"www.hoplr.com\",\n\n"
+ " \"endpoint\": \"*.hoplr.*\",\n\n"
+ " \"endpoint\": \"com.hoplr\",\n\n"
+ " \"name\": \"IAM KU Leuven\",\n\n"
+ " \"endpoint\": \" account.kuleuven.be\",\n\n"
+ " \"endpoint\": \" idp.kuleuven.be\",\n\n"
+ " \"name\": \"Jooki\",\n\n"
+ " \"endpoint\": \"*.jooki.rocks\",\n\n"
+ " \"endpoint\": \"*.muuselabs.com\",\n\n"
+ " \"endpoint\": \"my.jooki.rocks\",\n\n"
+ " \"name\": \"KU Leuven - www.kuleuven.be\",\n\n"
+ " \"endpoint\": \"www.kuleuven.be/english/\",\n\n"
+ " \"endpoint\": \"www.kuleuven.be\",\n\n"
+ " \"name\": \"Monster Worldwide\",\n\n"
+ " \"endpoint\": \"*.military.com\",\n\n"
+ " \"endpoint\": \"*.monster.at\",\n\n"
+ " \"endpoint\": \"*.monster.be\",\n\n"
+ " \"endpoint\": \"*.monster.ca\",\n\n"
+ " \"endpoint\": \"*.monster.ch\",\n\n"
+ " \"endpoint\": \"*.monster.co.uk\",\n\n"
+ " \"endpoint\": \"*.monster.com\",\n\n"
+ " \"endpoint\": \"*.monster.cz\",\n\n"
+ " \"endpoint\": \"*.monster.de\",\n\n"
+ " \"endpoint\": \"*.monster.dk\",\n\n"
+ " \"endpoint\": \"*.monster.es\",\n\n"
+ " \"endpoint\": \"*.monster.eu\",\n\n"
+ " \"endpoint\": \"*.monster.fi\",\n\n"
+ " \"endpoint\": \"*.monster.fr\",\n\n"
+ " \"endpoint\": \"*.monster.hu\",\n\n"
+ " \"endpoint\": \"*.monster.ie\",\n\n"
+ " \"endpoint\": \"*.monster.it\",\n\n"
+ " \"endpoint\": \"*.monster.lu\",\n\n"
+ " \"endpoint\": \"*.monster.no\",\n\n"
+ " \"endpoint\": \"*.monster.pt\",\n\n"
+ " \"endpoint\": \"*.monster.se\",\n\n"
+ " \"endpoint\": \"*.monsterboard.nl\",\n\n"
+ " \"endpoint\": \"*.monsterpolska.pl\",\n\n"
+ " \"name\": \"Nexuzhealth\",\n\n"
+ " \"endpoint\": \"mobile.nexuzhealth.be\",\n\n"
+ " \"endpoint\": \"mynexuz.be\",\n\n"
+ " \"endpoint\": \"mynexuz.be/myUZ/\",\n\n"
+ " \"endpoint\": \"www.nexuzhealth.be/en\",\n\n"
+ " \"name\": \"Nexuzhealth Web PACS\",\n\n"
+ " \"endpoint\": \" idp-contact.nexuzhealth.be\",\n\n"
+ " \"endpoint\": \"media.nexuzhealth.be/patient/ \",\n\n"
+ " \"name\": \"Online enrollment for students\",\n\n"
+ " \"endpoint\": \"https://associatie.kuleuven.be/inschrijvingen/oli_login_50000050\",\n\n"
+ " \"endpoint\": \"https://webwsp.aps.kuleuven.be/sap/bc/ui5_ui5/sap/zc_oi_appl/\",\n\n"
+ " \"name\": \"Phished\",\n\n"
+ " \"endpoint\": \"*.phished.be\",\n\n"
+ " \"name\": \"Port of Antwerp\",\n\n"
+ " \"endpoint\": \"*.c-point.be\",\n\n"
+ " \"endpoint\": \"*.portofantwerp.com\",\n\n"
+ " \"name\": \"Randstad\",\n\n"
+ " \"endpoint\": \"*.randstadrisesmart.*\",\n"
+ " \n"
+ " \"endpoint\": \"*.risesmart.*\",\n\n"
+ " \"endpoint\": \"*.randstad.*\",\n"
+ ",\n"
+ " \"name\": \"Red Bull\",\n\n"
+ " \"endpoint\": \"*.redbull.com\",\n\n"
+ " \"name\": \"Sentiance\",\n\n"
+ " \"endpoint\": \"*.sentiance.com\",\n\n"
+ " \"endpoint\": \"docs.sentiance.com\",\n\n"
+ " \"name\": \"Speakap Responsible Disclosure\",\n\n"
+ " \"endpoint\": \"*.speakap.com\",\n\n"
+ " \"endpoint\": \"*.speakap.io\",\n\n"
+ " \"name\": \"Suivo\",\n\n"
+ " \"endpoint\": \" aweb.suivo.com\",\n\n"
+ " \"endpoint\": \"asupport.suivo.com\",\n\n"
+ " \"name\": \"Telenet - Base \",\n"
+ " \n"
+ " \"endpoint\": \"https://www2.telenet.be/nl/landing-pages/safespot\",\n"
+ " \n"
+ " \"endpoint\": \"*.9lives.be\",\n"
+ " \n"
+ " \"endpoint\": \"*.base.be\",\n"
+ " \n"
+ " \"endpoint\": \"*.telenet.be\",\n\n"
+ " \"endpoint\": \"*.telenethotspot.be \",\n"
+ " \n"
+ " \"endpoint\": \"*.yelo.be\",\n"
+ " \n"
+ " \"endpoint\": \"*.yeloplay.be\",\n"
+ " \n"
+ " \"name\": \"Tempo-Team \",\n"
+ " \n"
+ " \"endpoint\": \"www.tempo-team.com\",\n"
+ " \n"
+ " \"endpoint\": \"www.tempo-team.nl\",\n"
+ " \n"
+ " \"endpoint\": \"www.tempo-team.be\",\n"
+ " \n"
+ " \"endpoint\": \"*.tempo-team.*\",\n"
+ " \n"
+ " \"name\": \"Tomorrowland\",\n"
+ " \n"
+ " \"endpoint\": \"artists.tomorrowland.com/production-website/33117\",\n"
+ " \n"
+ " \"endpoint\": \"cognito-idp.eu-west-1.amazonaws.com\",\n"
+ " \n"
+ " \"endpoint\": \"globaljourney.tomorrowland.com\",\n"
+ " \n"
+ " \"endpoint\": \"mdm.weareone.world\",\n"
+ " \n"
+ " \"endpoint\": \"my.tomorrowland.com\",\n"
+ " \n"
+ " \"endpoint\": \"oneworldradio.tomorrowland.com\",\n"
+ " \n"
+ " \"endpoint\": \"sp1y1tpaf1.execute-api.eu-west-1.amazonaws.com\",\n"
+ " \n"
+ " \"endpoint\": \"winterpackages.tomorrowland.com\",\n"
+ " \n"
+ " \"endpoint\": \"www.tomorrowland.com\",\n"
+ " \n"
+ " \"name\": \"Torfs\",\n"
+ " \n"
+ " \"endpoint\": \"winkels.torfs.be\",\n"
+ " \n"
+ " \"endpoint\": \"www.schoenentorfs.be\",\n"
+ " \n"
+ " \"endpoint\": \"www.schoenentorfs.nl \",\n"
+ " \n"
+ " \"endpoint\": \"www.torfs.be\",\n"
+ " \n"
+ " \"endpoint\": \"www.torfs.nl\",\n"
+ " \n"
+ " \"endpoint\": \"www.samenfittorfs.be\",\n"
+ " \n"
+ " \"endpoint\": \"www.sterkinjeschoenen.be\",\n"
+ " \n"
+ " \"endpoint\": \"www.torfssuppliers.be\",\n"
+ " \n"
+ " \"name\": \"Trouw\",\n"
+ " \n"
+ " \"endpoint\": \"*.trouw.nl\",\n"
+ " \n"
+ " \"endpoint\": \"abonnement.trouw.nl\",\n"
+ " \n"
+ " \"endpoint\": \"login2.trouw.nl\",\n"
+ " \n"
+ " \"endpoint\": \"myaccount.trouw.nl\",\n"
+ " \n"
+ " \"endpoint\": \"shop.trouw.nl\",\n"
+ " \n"
+ " \"endpoint\": \"webwinkel.trouw.nl\",\n"
+ " \n"
+ " \"endpoint\": \"www.trouw.nl\",\n"
+ " \n"
+ " \"name\": \"Twago\",\n"
+ " \n"
+ " \"endpoint\": \"*.twago.fr\",\n"
+ " \n"
+ " \"endpoint\": \"*.twago.it\",\n"
+ " \n"
+ " \"endpoint\": \"*.twago.com\",\n"
+ " \n"
+ " \"endpoint\": \"*.twago.de\",\n"
+ " \n"
+ " \"endpoint\": \"*.twago.es\",\n"
+ " \n"
+ " \"name\": \"Tweakers\",\n"
+ " \n"
+ " \"endpoint\": \"*.tweakblogs.net\",\n"
+ " \n"
+ " \"endpoint\": \"*.tweakers.net\",\n"
+ " \n"
+ " \"endpoint\": \"*.tweakimg.net\",\n"
+ " \n"
+ " \"name\": \"UZ Leuven\",\n"
+ " \n"
+ " \"endpoint\": \"www.uzleuven.be/en\",\n"
+ " \n"
+ " \"name\": \"VRT\",\n"
+ " \n"
+ " \"endpoint\": \"*.canvas.be\",\n"
+ " \n"
+ " \"endpoint\": \"*.dewarmsteweek.be\",\n"
+ " \n"
+ " \"endpoint\": \"*.een.be\",\n"
+ " \n"
+ " \"endpoint\": \"*.ketnet.be\",\n"
+ " \n"
+ " \"endpoint\": \"*.klara.be\",\n"
+ " \n"
+ " \"endpoint\": \"*.mnm.be\",\n"
+ " \n"
+ " \"endpoint\": \"*.radio1.be\",\n"
+ " \n"
+ " \"endpoint\": \"*.radio2.be\",\n"
+ " \n"
+ " \"endpoint\": \"*.sporza.be\",\n"
+ " \n"
+ " \"endpoint\": \"*.stubru.be\",\n"
+ " \n"
+ " \"endpoint\": \"*.vrt.be\",\n"
+ " \n"
+ " \"endpoint\": \"be.vrt.ketnet.ketnet\",\n"
+ " \n"
+ " \"name\": \"VTM GO\",\n"
+ " \n"
+ " \"endpoint\": \"login2.vtm.be\",\n"
+ " \n"
+ " \"endpoint\": \"myaccount.vtm.be\",\n"
+ " \n"
+ " \"endpoint\": \"vtm.be/vtmgo\",\n"
+ " \n"
+ " \"endpoint\": \"vtmgo.be\",\n"
+ " \n"
+ " \"endpoint\": \"*.vtm.be\",\n"
+ " \n"
+ " \"endpoint\": \"*.vtmgo.be\",\n"
+ " \n"
+ " \"name\": \"eHealth Hub VZN KUL\",\n"
+ " \n"
+ " \"endpoint\": \"hub.vznkul.be/services/intrahub/IntraHubService\",\n"
+ " \n"
+ " \"endpoint\": \"hub.vznkul.be/services/interhub/InterHubService\",\n"
+ " \n"
+ " \"endpoint\": \"hubacc.vznkul.be/services/acceptance/intrahub/IntraHubService\",\n"
+ " \n"
+ " \"endpoint\": \"hubacc.vznkul.be/services/acceptance/interhub/InterHubService\",\n"
+ " \n"
+ " \"endpoint\": \"hub.vznkul.be/* \",\n"
+ " \n"
+ " \"endpoint\": \"hubacc.vznkul.be/*\",\n\n"
+ " \"name\": \"iBOOD.com\",\n\n"
+ " \n"
+ " \"endpoint\": \"www.ibood.com\",\n\n"
+ " \"name\": \"intigriti\",\n\n"
+ " \"endpoint\": \"*.intigriti.com\",\n\n"
+ " \"endpoint\": \"*.intigriti.io\",\n\n"
+ " \"endpoint\": \"*.intigriti.me\",\n\n"
+ " \"name\": \"itsme\",\n\n\n"
+ " \"endpoint\": \"mobileapp.itsme.be\",\n\n"
+ " \"endpoint\": \"business.itsme.be/en/\",\n\n"
+ " \"endpoint\": \"confluence.belgianmobileid.be\",\n\n"
+ " \"endpoint\": \"crowd.belgianmobileid.be\",\n\n"
+ " \"endpoint\": \"jira.belgianmobileid.be\",\n\n"
+ " \"endpoint\": \"merchant.itsme.be\",\n\n"
+ " \"endpoint\": \"my.itsme.be\",\n\n"
+ " \"endpoint\": \"www.belgianmobileid.be/en/\",\n\n"
+ " \"endpoint\": \"www.itsme.be/en/\",\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}