#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "rel=['"](?:shortcut )?icon['"] href=['"]([^?'"]+)[?'"]"
Local $sString = "<link rel="shortcut icon" href="https://cdn.sstatic.net/Sites/stackoverflow/Img/favicon.ico?v=ec617d715196">" & @CRLF & _
"<link rel="icon" href="https://www.ecotechie.io/wp-content/uploads/2019/05/cropped-EcoTechie-Logo-512x512-1-32x32.png" sizes="32x32" />" & @CRLF & _
"<link rel="icon" href="//ssl.gstatic.com/pagespeed/insights/ui/logo/favicon_48.png" sizes="48x48">" & @CRLF & _
"<link rel='shortcut icon' href='https://cdn.sstatic.net/Sites/stackoverflow/Img/favicon.ico?v=ec617d715196'>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")