const regex = /^((([13578]|0[13578]|1[02])\/([1-9]|0[1-9]|[12][0-9]|3[01]))|(([469]|0[469]|11)\/([1-9]|0[1-9]|[12][0-9]|30))|((2|02)\/([1-9]|0[1-9]|1[0-9]|2[0-9])))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((([13578]|0[13578]|1[02])\\\/([1-9]|0[1-9]|[12][0-9]|3[01]))|(([469]|0[469]|11)\\\/([1-9]|0[1-9]|[12][0-9]|30))|((2|02)\\\/([1-9]|0[1-9]|1[0-9]|2[0-9])))$', 'gm')
const str = `02/02
02/12
02/29
02/29
06/31
01/31
02/02
02/02
02/02
02/02
02/02
02/02
01/01`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}