const regex = /(^|\+|(?<=\s))(100|\d\d?)(?=(\s|$))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^|\\+|(?<=\\s))(100|\\d\\d?)(?=(\\s|$))', 'gm')
const str = `0 Sam has 200 apples. He gives Todd 20 and Mary 125. and The weather is -5 C today, but will be +5 C tomorrow. 0 101 100`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}