use strict;
my $str = '
<p> Праздничную иллюминацию в Липецке прежде традиционно отключали 15 января. Однако в этом году она будет работать до конца месяца, соответственно дольше обычного жители областного центра смогут любоваться световыми арт-объектами и нарядными новогодними елками. Такое решение принял глава города Сергей Иванов.Как сообщил председатель департамента дорожного хозяйства и благоустройства Алексей Бахтин, идея навеяна самой нынешней зимой. Яркие краски светового оформления города подчеркнут красоту заснеженных улиц и продлят праздничное настроение липчанам. </p>
<t> В администрации Липецка - незаурядная отставка: уходит управделами Виктор Ивлев, житель Тербунов, которого в мэрию привел его земляк Сергей Иванов, ставший главой города волей Липецкого горсовета в декабре 2015 года. Последним местом работы Виктора Ивлева в Тербунах была должность председателя районной территориальной избирательной комиссии.
- 14 января станет последним днем работы Виктора Денисовича. Он принял такое решение по состоянию здоровья. Недавно он перенес тяжелую операцию на сердце и решил уйти с должности на пенсию, - прокомментировал GOROD48 циркулирующие слухи об отставке управделами мэрии глава Липецка Сергей Иванов. </t>(?<=<title>)(.*)(?=</title>)';
my $regex = qr/(?<=<p>)(.*) (?=</p>)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}