import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "APDNUDES_F20[0-9]{2}_((?:[A-Za-z]+-?)*-in-(?:[A-Za-z]+-?)*)_[P|V][0-9]+(\\.[\\w]{3,4})?";
final String string = "APDNUDES_F2013_Sammi-Tye-in-Beauty_V190522172041.mp4\n"
+ "APDNUDES_F2013_Sammi-Tye-in-Classic-Curves_V190522161615.mp4\n"
+ "APDNUDES_F2013_Sammi-Tye-in-Classy-Erotica_V190522173336.mp4\n"
+ "APDNUDES_F2013_Sammi-Tye-in-Classy-Erotica_V190522173336\n";
final String subst = "${1}${2}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}