$re = '/((\d+\.)+\d*)/m';
$str = '7-Zip (x64) 19.00.15
Acronis True Image OEM 19.0.5158
4K Video Downloader 4.19.3.4700
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);