$re = '/^[A-Z]{2}[0-9]{2}[A-Z]{2}[0-9]{4}$/m';
$str = 'GJ12VC2345';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);