re = /^[a-zA-Z0-9]+@.[a-z]+.[a-z]+$/m
str = 'kayush232@gmail.com
email@example.com
firstname.lastname@example.com
email@subdomain.example.com
firstname+lastname@example.com
email@123.123.123.123
email@[123.123.123.123]
"email"@example.com
1234567890@example.com
email@example-one.com
_______@example.com
email@example.name
email@example.museum
email@example.co.jp
firstname-lastname@example.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end