import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:demande|incident).*(?'num_externe'INC[0-9]*).*(?:\\n.*)*Nom\\s*:\\s*(?'ins_libl'.*\\)).*(?:\\n.*)*Ville\\s*:\\s*(?'apt_localisation'.*?)\\s*(?:\\n.*)*-\\s*Demandeur\\s*:\\s*(?'apt_nom'.*?,.*?),(?'apt_telephone'.*?),.*(?:\\n.*)*Cat.gorie\\s*:\\s*(?'tsy_lib'.*?)\\s*(?:\\n.*)*\\s*-.*Description.*?:\\s*(?:\\n.*)*\\s*o\\s*(?'commentaire_externe'.*?)\\s*\\n";
final String string = "<![CDATA[ Bonjour, \n"
+ " \n"
+ " La facture proforma de la demande n°INC0937639 a été mise à jour Pour accéder à ce dossier de nature " demande ", cliquer ici . \n"
+ " Détail des informations : \n"
+ " - Date de création : 21/03/2019 15:51:54 \n"
+ " - Site concerné : \n"
+ " o Nom : RRAA COURS LA VILLE (00363800) \n"
+ " o Etage : \n"
+ " o Bureau : \n"
+ " o Adresse 1 : 55 RUE GEORGES CLEMENCEAU \n"
+ " o Adresse 2 : \n"
+ " o Ville : COURS LA VILLE \n"
+ " o CP : 69470 \n"
+ " o Téléphone : 0474647881 \n"
+ " o Fax : 0474647888 \n"
+ " - Horaires du site : \n"
+ " o Statut : Ouvert LP : BERNARD,franck Lu=Fermé Fermé Ma=08H30-12H00 13H30-17H45 Me=08H30-12H00 13H30-17H45 Je=08H30-12H00 14H15-17H45 Ve=08H30-12H00 13H30-17H45 Sa=08H30-12H00 Fermé Di=Fermé Fermé \n"
+ " - Demandeur : FILLON,LOREN,0474647881, \n"
+ " - Logisticien : \n"
+ " o Monsieur BERNARD, franck \n"
+ " - Equipe d'affectation :LP \n"
+ " - Intervenant : BERNARD franck \n"
+ " - Catégorie : MULTITECHNIQUE\\Petits travaux\\Menuiserie \n"
+ " - Description du dossier : \n"
+ " o Pose d'une plaque pour boucher l'ouverture sur la boite aux lettres bureau RA \n"
+ " \n"
+ " Pour accéder à ce dossier, cliquer ici . \n"
+ " ]]>\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}