// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^[\s\S]{0,30}").unwrap();
let string = "</head>
<body>
<div id=\"kJAQ_\" class=\"z-temp\"><div id=\"zk_proc\" class=\"z-loading\"><div class=\"z-loading-indicator\"><span class=\"z-loading-icon\"></span>Processing...</div></div></div>
<script class=\"z-runonce\" type=\"text/javascript\">
zkmx(
[0,'kJAQ_',{dt:'z_oec',cu:'/EfectoresWeb',uu:'/EfectoresWeb/zkau',ru:'/login.isp'},[
['zul.utl.Style','zk_comp_1',{visible:false,src:'/EfectoresWeb/css/PamiStyle.css'},[]],
['zul.wgt.Div','zk_comp_2',{id:'div',style:'width:90%;margin:0 auto 0 auto;align:center',prolog:'\\n\\t'},[
['zul.wgt.Include','zk_comp_3',{prolog:'\\n\\t\\t',_xcnt:'<div id=\"kJAQ0\" class=\"z-temp\"><div id=\"zk_proc\" class=\"z-loading\"><div class=\"z-loading-indicator\"><span class=\"z-loading-icon\"></span>Processing...</div></div></div>',_childjs:function(){zkmx(
[0,'kJAQ0',{ow:'zk_comp_3'},[
['zul.wnd.Window','zk_comp_38',{id:'winHeader',$$onSize:false,$$onMaximize:false,$$onOpen:false,$$onMinimize:false,$$onZIndex:false,$onClose:true,$$onMove:false,prolog:'\\n\\t'},[
['zul.box.Box','zk_comp_39',{},[
['zul.box.Box','zk_comp_40',{id:'hbox_header',align:'end'},[
['zul.wgt.Image','zk_comp_41',{src:'/EfectoresWeb/img/top.jpg'},[]]],'horizontal']],'vertical']]]]]);
}},[]],
['zul.wnd.Window','zk_comp_4',{id:'winLogin',$onOK:true,$onClose:true,prolog:'\\n\\t \\t'},[
['zul.box.Box','zk_comp_5',{},[
['zul.box.Box','zk_comp_6',{id:'hbox_menu'},[],'horizontal'],
['zul.wgt.Groupbox','zk_comp_7',{$$onOpen:false,width:'890px',closable:false},[
['zul.wgt.Caption','zk_comp_8',{id:'caption_login',sclass:'z-title',label:'Login'},[]],
['zul.grid.Grid','zk_comp_9',{$$onRender:true,$";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}