$re = '/^(\d+\.?\d*)(h|m|s|ms|f|t)$/m';
$str = '11
11s
11.1222s
33ms
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);