package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\s*\[.*@.*\]#\s*$`)
var str = `[root@rsva ~]#`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}