package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(.*?)\s(\d{1,2})(?::(\d{1,2})(?:-(\d{1,2})?)?)?`)
var str = `2 Timothy 28:10-11`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}